Thank you for the short videos.  It’s helping me go back in and figure out why we are unable to get clients registered to the CMG from the internet.  We had 1910 in our environment when we set up the CMG, with a PKI cert installed and not trusted root cert.  DNS CNAME records created internally and external DNS.  Currently, the environment is set up EHTTP and no AAD/HAAD joined devices.  We upgraded to ConfigMgr 2002, to use the token, so we wouldn’t have to register devices in AAD and the OS Versions are not restricted..  Since we were having no luck, I added our Trusted Root Cert to the CMG.  We’ve tried bulk token registration before I added the Trusted Root Cert and it started to install the client, but failed.  After I’ve added the Trusted Root it will download all files but the ccmsetup.cab from the CMG and install fails immediately.  It seems, once we switched over to the CMG that all of a sudden I’ve got warnings and critical messages in component status on mp controller for guids, inventory data loader issues, state system if flooded with messages.  Everything I see from a CMG perspective is set up as it should be.  Any advice?  Should we remove the PKI cert and go to a public provider and remote the trusted root cert too?  When I upgraded from 1910 to 2002, the Primary server did have the ConfigMgr Client on it.  To fix the mp control manager, i was going to uninstall the internal MP, remove client reboot, and reinstall the MP.  One of the messages I remember reading said something about the component not installing properly after the upgrade.  Thanks for the advice.